Latest Diablo 3 News
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

What version(s) are you playing?

Discussion in 'Single Player Forum' started by Thyiad, Jul 25, 2016.

?

What are you playing?

Poll closed Jul 28, 2016.
  1. 1.00

    3 vote(s)
    9.1%
  2. <1.07

    3 vote(s)
    9.1%
  3. 1.07

    8 vote(s)
    24.2%
  4. 1.08

    1 vote(s)
    3.0%
  5. 1.09

    5 vote(s)
    15.2%
  6. 1.11

    0 vote(s)
    0.0%
  7. 1.12

    0 vote(s)
    0.0%
  8. 1.13

    21 vote(s)
    63.6%
  9. 1.14

    13 vote(s)
    39.4%
Multiple votes are allowed.
  1. Thyiad

    Thyiad Moderator Single Player, D2 Assassin, Barbarian

    Joined:
    Mar 3, 2006
    Messages:
    15,022
    Likes Received:
    238
    Trophy Points:
    488
    Seems a lot of time-travelling stuff going on at the moment.

    Just wondered what was the most-favoured version in the SPF? :D

    So what are you playing? (You can pick more than one.)
     
  2. maareek

    maareek Diabloii.Net Member

    Joined:
    May 12, 2007
    Messages:
    2,450
    Likes Received:
    540
    Trophy Points:
    310
    I play solely 1.13. I've seen no reason to update to 1.14 and I've never wanted to bother with starting over in an older patch.
     
    Kitteh likes this.
  3. TheNix

    TheNix Diabloii.Net Member

    Joined:
    Jun 23, 2003
    Messages:
    4,011
    Likes Received:
    389
    Trophy Points:
    494
    I am primarily playing 1.13 (when I'm not playing Grim Dawn that is), but I do pop back to 1.09 & 1.07 for the fun of it on occasions. Until there is some new content, I have no intention of going to 1.14.
     
  4. LiquidClear

    LiquidClear Diabloii.Net Member

    Joined:
    Mar 16, 2006
    Messages:
    478
    Likes Received:
    239
    Trophy Points:
    120
    I'm in 1.13 and nothing else. When I recently downloaded the game on my new computer from bnet, it installed 1.14 but seemed to do so in a manner in which the subfolders were no longer there. I couldn't figure out where to put stuff for the Runeword Mod, so I found a 1.13d game install and used that instead. I don't see a reason to go to 1.14 either, other than maybe some attempt at uniformity... but I don't see that happening anyways.
     
  5. helvete

    helvete Diabloii.Net Member

    Joined:
    Jul 17, 2004
    Messages:
    6,995
    Likes Received:
    1,173
    Trophy Points:
    534
    I play every patch for research, nostalgia, OP items and fun. In addition to the options in the poll, I also play the two 1.10 beta patches.
     
    T72on1 and DiabloTwoinDC like this.
  6. RadTang

    RadTang Diabloii.Net Member

    Joined:
    Mar 8, 2016
    Messages:
    489
    Likes Received:
    64
    Trophy Points:
    107
    So prediction was right - You or Treeharl casted the vote on 1.0 ;)

    I don't remember which version of LoD I had when I played the game for the first time. It was probably 1.10+ but I don't know and I don't have these discs. The game was pirated but I never finished the A4. Bought the legal edition few years ago of course. ;) And registered the keys for bnet client.
     
  7. krischan

    krischan Europe Trade Moderator

    Joined:
    Aug 17, 2003
    Messages:
    30,144
    Likes Received:
    1,138
    Trophy Points:
    416
    I'm playing whatever is the latest patch, but I'm playing with the thought of trying a few exotic patch levels, like those before the release of the expansion or LoD 1.07.

    BTW, how do you prevent an automatic upgrade when accidentally clicking on the bnet button? It could be achieved e.g. through a minimum installation or by using a differen Windows account or setting up a virtual machine.
     
  8. RadTang

    RadTang Diabloii.Net Member

    Joined:
    Mar 8, 2016
    Messages:
    489
    Likes Received:
    64
    Trophy Points:
    107
    For LoD only major versions (1.07 but supports 1.09b, 1.10f though no 1.10s) there's a tool for it. Works like a charm. It's a mod manager for D2. Works with Median XL and Eastern Sun too (though you need to download the versions supported by this manager - they're final). Hope I helped ! This tool is not to be talked about here, unfortunately, as it comes with other one that is forbidden.
     
  9. Gripphon

    Gripphon Diabloii.Net Member

    Joined:
    Sep 11, 2009
    Messages:
    3,127
    Likes Received:
    1,910
    Trophy Points:
    248
    1.13 only. Don't see a reason to upgrade to gain nothing and only have potential problems. Also tried to make 1.07 work, but couldn't figure out why is not working. Nor me nor Froz, and he has 1.07 working. Not meant to be, so only 1.13.
     
  10. krischan

    krischan Europe Trade Moderator

    Joined:
    Aug 17, 2003
    Messages:
    30,144
    Likes Received:
    1,138
    Trophy Points:
    416
    I guess I would use a different Windows account then, with the server list being messed up with 127.0.0.1 :)

    The additional HD space is irrelevant, 4 Gigs cost about 15 cent. It's just not going on the SSD.
     
  11. Burgomaster3

    Burgomaster3 Diabloii.Net Member

    Joined:
    Jan 19, 2016
    Messages:
    347
    Likes Received:
    498
    Trophy Points:
    105
    I currently play 1.13 and 1.07. Plan is to venture through other earlier patches in the future.

    I started time travel partly out of boredom, partly out of greed and curiosity. So far I've had a great time. I still consider 1.13 as my endgame though.

    I won't upgrade beyond 1.13 unless there are concrete updates to the gameplay, bugfixes, etc.
     
  12. RadTang

    RadTang Diabloii.Net Member

    Joined:
    Mar 8, 2016
    Messages:
    489
    Likes Received:
    64
    Trophy Points:
    107
    Anyway, I tried to run 1.07 but it didn't even started :( I don't know why.

    Edit: Fixed it ! At least for me, switching compatibility to Windows XP (SP 3) helped. No other options. Now 1.07 works and all mods. The other banned mod here works too but it's switchable so you can switch it off for 1.08+ LoD.
     
  13. pharphis

    pharphis Diabloii.Net Site Pal

    Joined:
    Aug 1, 2011
    Messages:
    13,903
    Likes Received:
    1,869
    Trophy Points:
    283
    If you click on bnet just hit esc and it won't do anything. I've been a few seconds late before and there's no problem, but it usually takes no more than 1.5 sec to realize the mistake and correct it
     
  14. Rmmhc

    Rmmhc Diabloii.Net Member

    Joined:
    Sep 25, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I'm running through 1.00, 1.09, and 1.13c right now.
     
  15. Brak

    Brak Diabloii.Net Member

    Joined:
    Aug 19, 2006
    Messages:
    1,948
    Likes Received:
    674
    Trophy Points:
    233
    I'm on 1.13 for the most part. But I have one laptop where the CD drive is shot, so the only way I could install D2 on it was going to 1.14

    PS: Do you see any chance of 1.13 and 1.14 being seen as compatible somewhat like 1.10 and 1.11 where in the past?
     
  16. RadTang

    RadTang Diabloii.Net Member

    Joined:
    Mar 8, 2016
    Messages:
    489
    Likes Received:
    64
    Trophy Points:
    107
    As the most changes known to me are rather relating to compatibility with modern PCs, I think that 1.13 and 1.14 are totally compatible. At least for now. Maybe we will get 1.15 or 1.14e with more significant changes.
     
  17. fearedbliss

    fearedbliss Diabloii.Net Member

    Joined:
    Jun 29, 2011
    Messages:
    395
    Likes Received:
    107
    Trophy Points:
    247
    You just need to remove the gateways available from the D2 list.. that way if you click the battle.net button, it won't connect to anything. I don't think it would be a problem to mention the name since it isn't a hack or anything, just a UI that modifies the registry for D2. The program is called "Battle.net Gateway Editor".

    [​IMG]

    @krischan You can use my version switcher and then all your HDD space problems will be gone.

    @RadTang My Singling pack includes the Mini-Images so you can play 1.00 - 1.11 without the CD. Remember that Singling is SPF approved.

    @RadTang @krischan Also you can download the "Bliss Complete Collection" if you want all of the D2 version, the version switcher, and Singling in one download.

    http://www.diabloii.net/forums/threads/bliss-version-switcher.849147/
     
    Last edited: Jul 25, 2016
    ioupainmax and maxicek like this.
  18. JoeBruce

    JoeBruce Diabloii.Net Member

    Joined:
    Apr 23, 2005
    Messages:
    465
    Likes Received:
    171
    Trophy Points:
    157
    I have been in 1.13 for a long time and only recently found out about 1.14

    One of my best friends - we used to play D2 back in the day - decided he wanted to play again, so we will be starting a pair of characters in 1.14, probably later today (he installed from the online download so we didn't have much of a choice).

    I will probably keep the rest of my chars/stashes in 1.13 for now, though.
     
  19. Brak

    Brak Diabloii.Net Member

    Joined:
    Aug 19, 2006
    Messages:
    1,948
    Likes Received:
    674
    Trophy Points:
    233
    I dont mean PC compatibility, I mean trade pool, tournies etc.
     
  20. RadTang

    RadTang Diabloii.Net Member

    Joined:
    Mar 8, 2016
    Messages:
    489
    Likes Received:
    64
    Trophy Points:
    107
    Then, if nothing like runewords or crafting recipes or affixes were touched and they're same as 1.13, the 1.14 line should be exactly the same like 1.13. So, it should be compatible.

    Edit:

    Thanks @fearedbliss
     
    Last edited: Jul 25, 2016
    fearedbliss likes this.

Share This Page