Tech problem - new computer...

queenEm

Diabloii.Net Member
So my old laptop died on me and now I have a new one. Win8.1 and an NVIDIA graphic card. And D2 is just crap!!! It lags and jumps around is it's like I have a bad connection only I am playing SP...

I have been doing som searching and I think the problem is that the laptop wants to run all games on the nvidia graphic card but D2 can only use the internal one which is not made for that kind of playing. I have tried playing in windows mode and that makes it a bit better but it's still annoying as hell.

Anyone got any suggestions?
 

srrw

Diabloii.Net Member
Try running D2VidTest.exe in you D2 folder. It usually asks which video card to use at the end of the test.

If that doesn't work things can get a bit complicated so try that first.
 

queenEm

Diabloii.Net Member
choose 2d mode

what are your PC-Data? i mean ram, videocard etc
How do I choose 2D mode?

Try running D2VidTest.exe in you D2 folder. It usually asks which video card to use at the end of the test.

If that doesn't work things can get a bit complicated so try that first.
I couldn't start the test... The screen blipped and then nothing.

Does this have anything to do with admin rights etc? I am running D2 as administrator
 

srrw

Diabloii.Net Member
Right click -> Run as Administator

The screen should flash a couple of times then a menu will pop up to choose which video mode/video card to use. I think both Direct3D and DirectDraw should work fine, you can always redo the test so just try which works better.
 

queenEm

Diabloii.Net Member
The meny doesn't pop up. Even if I run it as admin

In the NVIDIA setting you can make choices if you want too run a program with the nvidia card or the internal but for D2 you can only choose the internal
 

srrw

Diabloii.Net Member
If even the initial setup doesn't pop up (asks you if you want to Run/Skip/Cancel the test) than it's Windows, being Windows and it should run OK if ran as Administrator (maybe Windows 7 Compatibility). If the test runs and then doesn't pop up the window where you choose your modes, restart your computer and try again.
 

queenEm

Diabloii.Net Member
I get a question if I want to allow this program to make changes to the harddrive. I say yes. It flickers and then nothing
 

srrw

Diabloii.Net Member
Last thing I can think of without seeing it first-hand is Right Click/Properties -> Compatibility Tab -> Tick Run as Admin and Compatibility mode to Windows 7/XP.

I'm not sure how this works with Windows 8 but it should be similar - go to the Action Center (in the Control Panel) -> Change User Account Control settings -> Select Never notify.

After you've done both of those, restart, try running it again. Whether it works or not change back your Notification settings as they were before.

A friend had a similar issue where his dual-gfx laptop would only run the integrated crappy graphics card instead of the decent one but I haven't owned an NVIDIA card in years and can't really help you there. I'm sure someone else knows how to configure it, tho.
 
Last edited:

thefranklin

Diabloii.Net Member
Did you install D2 under program files? I am not sure if a reinstall would fix this, but if you do happen to reinstall, do not install it in program files. Just install it to "Diablo 2" (or whatever folder you want) straight onto the C drive. Newer versions of windows do different things to program files folders than to folders in other locations.
 

queenEm

Diabloii.Net Member
Try 3dxglide wrapper. It's the only way I can play D2 in my win8.1 laptop.
Is this the one specialluy made for D2? I tried it but if I read ht einstructions correctly I need to be able to get the D2Vidtst exe going?
 

queenEm

Diabloii.Net Member
Did you install D2 under program files? I am not sure if a reinstall would fix this, but if you do happen to reinstall, do not install it in program files. Just install it to "Diablo 2" (or whatever folder you want) straight onto the C drive. Newer versions of windows do different things to program files folders than to folders in other locations.
Hmm... I might do this. It takes some time though
 

maareek

Diabloii.Net Member
As thefranklin said you probably want to install D2 in My Documents or straight to the Desktop because of some of the protection used by Windows for Program Files nowadays. That may or may not help this problem, but it will definitely lessen the chance of others down the way.

Are all your graphics drivers up to date? nVidia and Intel?

I did a quick google search and it seems people have had this issue with Diablo 3 and perhaps some of the solution(s) can be used here. I'll quote some of the steps from the one that seems most likely to help here:

3. [IMPORTANT] make sure your lappy power plan (control panel > system and security > power options) is on high performance and not power saver. for me, after weeks of trying various solutions given in the forum i.e. -launch, -usepageflip, nvidia inspector etc. nothing worked, actually my laptop was using the intel graphics all along, since my power plan was on power saver. so windows tells every program to not use nvidia gpu (I assume) to save power!!

4.now in nvidia control panel, in the global settings select multi display mixed gpu acc > single display performance mode and power management mode > prefer maximum performance.

5.now its time to check if diablo 3 is actually using intel graphics or nvidia, apart from starting a game and looking for screen tearing and drop in fps, I found the easiest way. go to nvidia control panel and click desktop tab on the top-left. now make sure display gpu activity is shown on notification area, you can disable this option once this solution starts working for you.

6. now start diablo and alt tab and click the NVIDIA GPU activity on the notification area in your desktop, next to where you see the time and date. it should display diablo 3 icon.
Steps 1 and 2 were just ensuring each graphics driver was up to date.

I don't have an actual experience with gaming on a laptop, and not much experience with them at all, but this plan does at least make sense to me as something worth attempting.
 

Thyiad

Moderator Single Player, D2 Assassin, Barbarian
My 8.1 laptop with GTX765M, directx 11 is running D2:
- Game installed in D://D2/Program Files (x86)/DiabloII
- Ran the D2VidTst by Right Click and Trouble shoot compatibility mode
- It decided to go with Win7 compatibility and I saved that
- Manually set it to run as 2D and not 3D as it wanted and that helped a lot
- Ran Diablo II by right clicking and trouble shoot compatibility mode
- It chose Win XP SP3 and I saved that

It's running like that pretty well.

Although:
- I am not running the most uptodate drivers; I will but it's ok
- I probably wouldn't run Atil (98) but would be happy with anything else

Good luck.

EDIT:
I'm running D3 straight off the bat. No compatibility fixes required at all.
 

queenEm

Diabloii.Net Member
I reinstalled (in another folder than program) and then followed Thy's excellent steps for the test program and now it looks so much better!! Thanks a lot for all the advice. I have to admit that when I yesterday saw the possibility that D2 actually has an end date I cried a little. Yes I may be a bit sleep deprived and emotional but still. The idea of not having this game any more is scary.

I am not finished with it yet!!
 

krischan

Europe Trade Moderator
If there is an end date of D2 (which I doubt), then I will install it in a virtual machine with Win 98 or so on it (which I already have done BTW) and the date being set back to 2005 or so :D.

Perhaps you mean that bnet is going to end at some time. I don't think that will be the case that soon, as long as a certain amount of people are playing. You can even still play D1 on bnet, as far as I know.

I still suggest to install the Glide wrapper because D2 is much more performant via the Glide API. By the way, on my Win7 computer I have to turn off the Windows Aero style to make D2 run properly in full screen.
 

Troy Leonard

Diabloii.Net Member
you need to run the vid test as admin in compatibility mode for xp sp2. there should also be a game.exe file in your diablo II directoryDiablo1 .JPG Diablo2.JPG Diablo3.JPG Diablo1 .JPG Diablo2.JPG Diablo3.JPG Diablo1 .JPG Diablo2.JPG Diablo3.JPG Diablo1 .JPG Diablo2.JPG Diablo3.JPG . add that to the nividia settings and use it to launch diablo you will be able to set your nvidia card as the default. you will then need to point your desktop short cut to the game.exe
 

queenEm

Diabloii.Net Member
Thanks for the advice. I will have to try that later on. Hopefully it works perfect and my MFO scores will automatically be a lot better :)
 
Top