Problems keeping connected to bnet, help!

Cerberus

Diabloii.Net Member
Problems keeping connected to bnet, help!

This is what happens:
Every time I log on to bnet and select a char, my computer freezes. After about 30 seconds the next screen comes up and I can play 1 game. After exiting that game I return to the log in screen (where I have to repeat the procedure).

No hacks, 3rd party, botting or whatever involved. I`ve even waited 48 hours before attempting to log on.

What made me suspiciuos was that this occured just after I switched to a wireless connection (router). Tried switching back, but still doesn`t work..
I`m no pro, so this might just be a real noob question, but any help ot hints would be greatly appreciated!
 

Cerberus

Diabloii.Net Member
superdave said:
are you running any firewalls?
I was actually, but turning it off (the new routers FW) didn`t make things better..

Tried updating the server list, but no luck with that either.
It`s getting kinda late over here now (4am) so I think I`ll check back tomorrow.

Thx for stopping by!
 

Senor Bezeer

Diabloii.Net Member
Cerberus said:
This is what happens:
Every time I log on to bnet and select a char, my computer freezes. After about 30 seconds the next screen comes up and I can play 1 game. After exiting that game I return to the log in screen (where I have to repeat the procedure).

No hacks, 3rd party, botting or whatever involved. I`ve even waited 48 hours before attempting to log on.

What made me suspiciuos was that this occured just after I switched to a wireless connection (router). Tried switching back, but still doesn`t work..
I`m no pro, so this might just be a real noob question, but any help ot hints would be greatly appreciated!
OH MY GOODNESS GRACIOUS!! I have experienced this exact, and I mean EXACT same thing as you!! and i mean to the last detail! Even the wireless router part!! Now im not so sure about my previous conclusion to the problem, which was that bnet was making changes. I am absolutely astounded. i have just switched to a wireless router, and whenever I try to enter a character, it freezes.........or at least it seems that way, but about a minute or 30sec later it signs me in. AND whenever I enter a game, all goes well until i exit the game, AND then is logs me out! It is absolutely frustrating! So i dont know whats going on, but now im thinking it might have to do with the wireless router. I hope you find a solution, or a cause for that matter because i haven't been so fortunate yet. Now, is it the problem the wireless router, or is it a huge coinsidence and bnet has made changes? if anyone else is experiencing this same problem, then maybe we can piece together the common factors. once again im completely amazed that im not the only one experiencing the same problem! :scratch:
 

sjw7

Diabloii.Net Member
Are you sure your not getting any popup boxes behind the Diablo2 window. Try running the game in windowed mode (-w switch on the shortcut) and see if anything appears on your screen. A bit of a long shot but its worth a try.
 

Cerberus

Diabloii.Net Member
Tried removing the new router altogether (doh.. ) now, and things are working fine. As plugging a cable into the new router and using it with my old network card and setup isn`t working (same thing is happening), I`m starting to think hardware problems..
D2 seems to be the only thing not working, too..

Gonna try messing a bit with the settings on this wireless piece of crap now.
Let u know if I find anything!
 

Senor Bezeer

Diabloii.Net Member
Thx, i seem to be having similar problems, running a hard wire from the wireless router still seems to affect the way b-net is working. I dont understand how only diablo is afffected though, I have tried playing Counter Strike using the wireless connection, and the latency actually goes down, in comparison to the hard wire.
 
Top