possible OT? Why am I lagging so much in single play? ifra

Zargo1z

Diabloii.Net Member
possible OT? Why am I lagging so much in single play?

Hey guys, been playing my necro and he's doing great so far, only problem is the lag i'm getting is pretty rough in some areas even for act 1. i looked through the tech tips on the site and did some of those things but it didnt' seem to help much, wanted to post here and see if you guys could come up with any ideas.

System Specs

P4 1.8ghz
60gig maxtor ultra dma harddrive
Soundblaster live 5.1 surround soundcard with creative 5.1 surround sound system
768 Sdram (have my swap file set to 2.5x my sdram) 1920 swap file i believe
Nvidia Geforce 128mb 6600GT AGP 8x
Windows XP OS
DSL FastAccess connection (shouldn't matter in single play i dont think but posted it just the same)

far from "uber" I know but i really dont get what's causing lag in an older game such as diablo 2 when i can play games like Doom3 and WoW on max or near max settings with no lag. sorry if this is the wrong forum to post this in, but it is for single play so i think maybe that should make it ok. is there something in an ini file or anything i might want to change or look at?

thanks for the advice,
Zargo

<edit> on and before anyone asks, i have all software drivers up to date
 

NSXdreamer

Diabloii.Net Member
What do you mean by "lag"? FPS going down the toilet or Ping going throught the roof?

I would assume you mean FPS, what is the exact number when you "lag"?

Are you running in direct3D, or directdraw mode? The code in d2 for direct 3d is utter crap, even my 2.8ghz, 1g ram, 6800GT craw down to 10 fps when a couple of sorcs show up. However in directdraw you can throw everything you got at it and still 75 fps no change.
 

Zargo1z

Diabloii.Net Member
NSXdreamer said:
What do you mean by "lag"? FPS going down the toilet or Ping going throught the roof?

I would assume you mean FPS, what is the exact number when you "lag"?
sorry yeah i mean FPS. can't post exact number atm about to leave the house, can post fps when i get back though. and also I've checked background programs running and only ones running when i play ANY game is the required system progs. maybe i should OC my video cards 2d settings or something hmm no clue kinda a benchmark junkie so try to keep my system optimized for video game performance above everything else.

Zargo

<edit> it reccomends when i run diablo 2 test to use direct3d settings, hmm should i change to directdraw 2d? maybe that's my problem
 

NSXdreamer

Diabloii.Net Member
Your card is definately fine, my old machine is 475 mhz, 128 ram, and 8mb onboard video, can run it fine.

I suspect it's because you are running in direct 3d mode, like I said, the code for d3d in d2 is utter crap.
 

lone_wolf

Diablo: IncGamers Member
diablo 2 where optimized for 2dfx glide running the game in directdraw is much much better then d3d.
 

ahcw

Diabloii.Net Member
Hmm, I hate to barge in here and hijack, but how do you run it in directdraw mode? I only ask because at certain times my fps drops to about 5 so this sounds like a good fix. [/hijack]
 

lone_wolf

Diablo: IncGamers Member
its quite simple in your diablo 2 folder you will find a file that is called D2VidTst.exe double click this file and it will do a video test for you. It will most likely say that direct3d is the best option for you but ignore that and mark directdraw instead.

Its hard to miss as there is only 2 choices to make direct3d or directdraw:)
 
Top