Need some help installing 1.09

joni1337

Diabloii.Net Member
Hey guys


I was trying to install diablo 2 and play patch 1.09 But im getting a weird error with my original copy The game asks for the disc with older versions (normal), but even tho i have my ORIGINAL d2 lod disc inside my pc, it wont recognize it somehow and keeps asking me to insert it.

I can install the game from those discs, no problem. I also noticed the same happens with d2 vanilla (it asks for the "Play CD" , which is already in my PC; again original CD from collectors box, for the install it works great, but somehow it wont recognize the CD when it tries to launch the game) I even tried a virtual CD drive at some point, and downloaded and ISO (because i wasnt sure my CD drive/ Disks weren broken somehow) But even THAT kept asking for CD.



I also tried the trick with copying the MPQ files from the disc into my d2 directory, EVEN THAT KEPT ASKING ME TO INSERT THE DISC (the disc was still in the CD drive; ORIGINAL LOD DISC; always worked for me)


Has anyone ever had this error? Does anyone know how to make the game recognize the CD???????

Not really sure what to do at that point, any idea would be appriciated
 

joni1337

Diabloii.Net Member
Hi, first of all thank you so much for the quick answer, really appriciate it <3

I downloaded the pack and added the 1.07 expansion game.exe
After that, the game asked for the "Play CD" (instead of expansion), I then inserted my Original d2 play cd, and the game finally launched!!!!!!! :)

Not sure if thats what should be happening (or if the patch should be "completely" no cd) but for me it solves the issue of not being able to launch at all (and my theory is, that i may have needed to insert both discs, diablo 2 and LOD, which i cant with only 1cd drive, but im not sure)

Anyways, it finally worked im super happy (wasnt able to launch the old versions for weeks now)

Thank you so much, i will try to figure out what was causing the problem and maybe get it to work even better, but for now im just happy :)

Thanks again and have a great day


Edit: I also added the MPQ's from the D2 disc to my directory, now it works as it should (sadly only with the galaxy patch, also tried the original "game.exe" still wont read the disc drive, its weird, idk whats wrong there but it works so im very happy, thanks so much for the help, wouldnt have figured it out on my own <3 <3 <3 )
 
Last edited:
Top