need 1.12 patch but cant find it

smilts

Diabloii.Net Member
Re: need 1.12 patch but cant find it

Thank you! Ill be reinstalling D2 and patching to 1.12 now....
 
Top