Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

Messed up colors in directdraw, slow in D3D

Discussion in 'Diablo 2 Patch Bug Reports & Suggestions' started by MagisterMan, Aug 2, 2010.

  1. MagisterMan

    MagisterMan IncGamers Member

    Joined:
    Jul 20, 2008
    Messages:
    453
    Likes Received:
    0
    Trophy Points:
    98
    Messed up colors in directdraw, slow in D3D

    So I installed Diablo II and LOD today. Everything went fine until I tried playing it.

    With Direct3D the game feels choppy and I have really bad FPS.
    I tried to change to DirectDraw instead. It felt smooth, but some colors are messed up (bright green, rainbow colors in certain places etc). I've had the same problem with wrong colors in other older games such as Starcraft, but they only appear in the menu, not when I am playing.

    My video card is a Intel Media Accelerator 4500mhd. It is a integrated video card so I didn't want to try the GLIDE-wrapper solution that was in the stickies. Also I have updated graphic drivers.

    Would really appreciate some help :)

    edit:Forgot to say I run XP
     
    Last edited: Aug 2, 2010
  2. ffejrxx

    ffejrxx IncGamers Member

    Joined:
    Nov 26, 2005
    Messages:
    6,286
    Likes Received:
    13
    Trophy Points:
    166
  3. nurman

    nurman IncGamers Member

    Joined:
    Dec 8, 2009
    Messages:
    4,365
    Likes Received:
    22
    Trophy Points:
    350
    Re: Messed up colors in directdraw, slow in D3D

    Type -w in front of the shortcut target field in order to run it in windowed mode.

    That should help.

    Also give us your CPU and RAM specifications.
     
  4. ffejrxx

    ffejrxx IncGamers Member

    Joined:
    Nov 26, 2005
    Messages:
    6,286
    Likes Received:
    13
    Trophy Points:
    166
    Re: Messed up colors in directdraw, slow in D3D

    ftfy

    ex. "C:\Games\Diablo II\Diablo II.exe" -w



     
  5. MagisterMan

    MagisterMan IncGamers Member

    Joined:
    Jul 20, 2008
    Messages:
    453
    Likes Received:
    0
    Trophy Points:
    98
    Re: Messed up colors in directdraw, slow in D3D

    I downloaded my drivers from Lenovo, and they were updated a month ago so they are not that old. I'll probably try to download the drivers from Intel's site tomorrow if I have time.

    Playing in windowed mode does work, but I'd rather play full screen.

    My comp is a x200s Thinkpad. 4gb RAM, Intel Core Duo CPU 1.86 GHz


     
  6. nurman

    nurman IncGamers Member

    Joined:
    Dec 8, 2009
    Messages:
    4,365
    Likes Received:
    22
    Trophy Points:
    350
    Re: Messed up colors in directdraw, slow in D3D

    Playing in the windowed mode fixed all problems?

    And just switching to the 2D option in the Vidtest didn't? That's quite weird.

    (Oh, and if you internal resolution is LARGER than 800x600 pixels, playing in windowed mode is better because the screen is not stretched =)
     
  7. Robelopethy

    Robelopethy IncGamers Member

    Joined:
    Mar 20, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Re: Messed up colors in directdraw, slow in D3D

    I have this problem, to solve it, you need to end the explorer.exe process while the game is running. To do this, press ctrl+alt+delete, and go into task manager. Then find the explorer.exe process under the correct tab, right click it and click "end process".
    Then click file->New Task (Run). On the window that pops up, click browse and find your diablo II.exe in program files. Click ok to run the game. When you're done playing, close the game and go to run again, type in explorer.exe to restart the explorer process.

    It's a bit tedious, but it's definitely worth it in terms of performance (i'm on the same integrated graphics).
    Hope this helps :)
     

Share This Page