Issues with D2 after windows update

T72on1

Diabloii.Net Member
Glad to hear things are working, although a bit strange the update broke things.


I see that as a bonus :D
Not when you are also playing a group game on BNet ;).

@drmalawi I already am at 1.14d. Or where you as well, and could you still patch the game, making BNet work again?
 

drmalawi

Diabloii.Net Member
@T72on1 I downloaded game from Blizzard, and it gave me 1.14B on installation. Bnet and patch in game did not work, so I patched manually and then I could connect to Bnet again.
 

Brak

Diabloii.Net Member
You can use -w for windowed mode as a temporary solution because it works just as well as before. Apart from being tiny..
can you not double click on the top of bar of the game window to roughly double the window size?
 

BKC

Diabloii.Net Member
glide wrapper lets you resize to any size you want it... :) i do the same thing atm
 

Albatross

Diabloii.Net Member
@BKC sadly, the option you told me about was already unchecked. I'm trying out various combinations, but nothing seems to help. The mouse still moves like I'm rolling it through grease and jumps to the corner of the screen if I open the char screen or the inventory.

@Brak forgot about that. It looks pretty ugly, but it's the best option I've got. Unless I roll back the windows updates, like @T72on1 did.. but that doesn't sound like a permanent solution.
 

Pijus

Diabloii.Net Member
I think when you use the glide wrapper and run in a window, you also need to pass the -w option to the game. This is supposed to help with the mouse jumping when you open inventory. Doesn't work on linux though.
 

krischan

Europe Trade Moderator
My recommendation regarding the latest patch level is as follows:

1. Install the downloaded archive or from CD.
2. Run as admin in order to upgrade to the latest patch, then quit.
3. Install Glide wrapper (dll into D2 dir, glideinit.exe anywhere).
4. Start glide-init.exe, click on "settings", put a checkmark at "desktopresolution".
5. Add -3dfx to the command line of the D2 shortcut/icon.
6. Play!

On Win7 (and Vista), you might have to switch off the Aero style thingy as well, but that problem might already be solved by step 4.
 

Albatross

Diabloii.Net Member
Finally had time to get to the bottom of this and managed to fix it, at least for my configuration.

My hunch was it had to do with resolution switching during load screens, which the troublesome windows patch in some way changed.
What fixed the issue was changing the desktop resolution to the highest available which wasn't in wide screen format and using these settings in the glide wrapper:

[ ] window-mode
[x] captured mouse
[ ] keep aspect ratio
[ ] vertical sync
[no] fps-limit
[no] static size
[ ] window extras
[auto] refreshrate
[x] desktopresolution

I don't think anything besides the non-wide res + desktopresolution really matters.

Win 10 does something quite interesting when you use a 4:3 (or similar) resolution on a wide screen LCD. This is why "captured mouse", which you'd normally use in windowed mode, was required. I've noticed my mouse pointer could go out of the expected window boundaries even though I was now running the game in full screen mode. This is probably because windows adds those black vertical lines instead of stretching the screen (which is great) but they confuse the game a bit.

It's slightly inconvenient having to change my resolution each time I want to do some runs, but beats installing a different version of windows hands down.
 

logoutzero

Diabloii.Net Member
Have you tried just leaving the screen where you adjust your resolution open in the background?

This disables a lot of modern video wizardry that screws with older games, and is the only way I can play the very early patches of the game.
 

krischan

Europe Trade Moderator
It's slightly inconvenient having to change my resolution each time I want to do some runs, but beats installing a different version of windows hands down.
I don't understand you here. If you activate desktop resolution, the resolution doesn't change, that's the point of it. The 800x600 Diablo screen gets blown up to the size of the desktop, keeping the ascpect ratio if activated. What are you going to change when doing runs and what's it when doing something else than that? What's the remaining problem?
 

Albatross

Diabloii.Net Member
My screen's native resolution is 1920x1200 (wide), but I have to drop to 1600x1200 to play DII and then switch back when I'm done. I used the term "do some runs" because that's the only thing I'm doing with DII nowadays.

This is preferable to waiting 15+ seconds between each run since the aforementioned win 10 patch got installed and the game seems to choke on loading screens.
 

krischan

Europe Trade Moderator
Perhaps I'm getting something completely wrong, but why do you think you have to switch to 1600x1200? You simply stay at 1920x1200, even though it's no 4:3 screenmode, put a checkmark to "keep aspect ratio" and have black bars to the left and and right. That's unavaoidable without distortions because your monitor is wider than 4:3.

I have a 1920x1200 monitor as well. My wrapper settings are like this:

[ ] window-mode
[x] captured mouse
[x] keep aspect ratio
[x] vertical sync
[no] fps-limit
[no] static size
[ ] window extras
[auto] refreshrate
[x] desktopresolution

Additional notes:

The vertical sync checkmark will sync the amount frame calculations with the frame rate of the monitor, as there's no need to calculate more of them.

If you want to play in windowed mode, activate it here, not via -w in the D2 command line, because by activating window extras, you can resize the window as you like.
 
Last edited:

Albatross

Diabloii.Net Member
I came to that conclusion by trial and error because nothing else worked. I'll double check when I get home, but I think the black bars are no longer there after the win patch, but the insanely long load times certainly are regardless of "keep aspect ratio" with which I was playing just fine before the patch hit.

Windowed mode (through the glide wrapper) makes the mouse pointer jump each time I open the char screen / inventory and overall feels like I'm dragging my mouse through grease. D2 native windowed mode (-w option) doesn't support gamma and is either 800x600 or "stretched to full screen" which is either tiny or looks horrible when stretched on larger screens.

Edit: got home and checked. With both aspect ratio and desktop resolution toggled the blacks bars are there, but the save/load performance is still really bad. Might be worth noting that things are slightly better when running vanilla (no -3dfx).
 
Last edited:
Top