Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

Immediate connection lost when selecting a skill (detailed)

Discussion in 'Diablo 2 Patch Bug Reports & Suggestions' started by MordainThade, May 20, 2008.

  1. MordainThade

    MordainThade IncGamers Member

    Joined:
    Feb 18, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    5
    Immediate connection lost when selecting a skill (detailed)

    So, here's the deal. I've got a Paladin with full Griswolds set equipped, and a Demon Limb on switch. I don't have the natural STR to equip the gear, but with all the assorted +STR from stuff (anni and torch, one other charm, actual gris set, Draul's, and Mara's) everything goes on just fine without problems (i.e. no self-sustaining items, a.k.a. the "strength glitch").

    The problem is when I have my main gear up, and I weapon switch to the Limb. Now, I have the skill hotkeyed so that I can roll straight to it. However, every time I do this, it disconnects me from the game immediately.

    This happens only when I have my main gear up. If I start a game with the limb equipped, I can mouse wheel roll through skills just fine. Switch over to complete Griswold set, switch back, and for some reason, the hotkey doesn't stay on Enchant... I roll to it, and *poof* disconnect.

    Just tested it, and it also occurs if I straight hit the hotkey for the skill as well. Switch from full gris to limb, hit F10 (my Enchant hotkey), instant disconnect. Also, if I select the skill from the bottom-right menu, the same happens.

    However, unequipping and re-equipping the Limb seems to work out... I can switch between skills no problem then. So, to make it so that selecting Enchant doesn't crash me, I've got to weapon switch to the Limb, open inventory, unequip and re-equip the Limb, then select Enchant.

    ???
     
  2. ffejrxx

    ffejrxx IncGamers Member

    Joined:
    Nov 26, 2005
    Messages:
    6,286
    Likes Received:
    13
    Trophy Points:
    166
    Re: Immediate connection lost when selecting a skill (detailed)

    using the mouse wheel to scroll through skills will give you ci

    try setting your mouse wheel to skills (1-16) instead of previous/next skills
    ingame, esc -> options -> configure controls
     
  3. korialstraz

    korialstraz IncGamers Site Pal

    Joined:
    Jun 11, 2007
    Messages:
    5,901
    Likes Received:
    11
    Trophy Points:
    166
    Re: Immediate connection lost when selecting a skill (detailed)

    That was my first though as well ffejrxx, but he also get disconnected when selecting the skill using the hotkey itself and when selecting it "manually" from the lower right corner. So it can't really be connected to scrolling too fast. Besides it's not like you scroll so fast that you get C/I by changing to a different skill. At least I never had that happen.

    As to a sollution. I'm really clueless. Never heard of such bug before.
     
  4. MordainThade

    MordainThade IncGamers Member

    Joined:
    Feb 18, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    5
    Re: Immediate connection lost when selecting a skill (detailed)

    I scroll through skills all the time with my Necromancer, and have never had a connection interrupt because of it. He even scrolls past the HoTo-granted Oak Sage without problems. With the pally, I can scroll through multiple skills repeatedly (though I usually don't... holy shield resets and TPs are the only reason I change my right mouse) without problems, except with the specific situation above.

    I think this is just another manifestation of the Strength glitch... now not only can others not see your gear when equipped, but selecting skills granted by those items causes disconnects.

    As a funny side-note, above I said that I wear complete Griswold's. Well, to others, I look naked (nowhere near enough natural STR to wear the set), but I still have my shiny aura :azn:
     
  5. MordainThade

    MordainThade IncGamers Member

    Joined:
    Feb 18, 2008
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    5
    Re: Immediate connection lost when selecting a skill (detailed)

    Just figured I'd give an update on this. I gave the pally enough STR so that his gear is now visible to others. It took a whole lot less STR than I thought it would... 30 more hard points (up to 78 natural STR) made everything but Griswold's shield visible, and five points after that, the shield could be seen as well.

    Once the Demon Limb was visible to other players, I was able to continually hotkey the skill and scroll to it with the mouse wheel, or press the hotkey and select it. Basically, it now works as any other skill, and doesn't cause the instant disconnect anymore.

    It definitely seems that this is a by-product of the age-old "strength display" bug. Another thing to fix if we every get a version 1.12 :thumbup:
     

Share This Page