Latest Diablo 3 News
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

How to lock cursor in window mode?

Discussion in 'Single Player Forum' started by PandadudeSP, Mar 8, 2015.

  1. PandadudeSP

    PandadudeSP Diabloii.Net Member

    Joined:
    Nov 15, 2008
    Messages:
    485
    Likes Received:
    68
    Trophy Points:
    149
    Hey guys, it's been a long time since ive been active here, but I just went and installed diablo 2 again.
    I run windows 7 now and when I have the game in fullscreen mode i can't tab back in to the game when i tab out. This is fine since you can now scale the windowed mode, except I'm afraid of clicking outside the screen playing hardcore. Any way to lock the cursor to the window?

    Cheers
     
  2. pharphis

    pharphis Diabloii.Net Site Pal

    Joined:
    Aug 1, 2011
    Messages:
    13,933
    Likes Received:
    1,887
    Trophy Points:
    283
    I would have never moved on to windowed mode without being able to do this.

    The only way I'm aware of is to use sven's glidewrapper and "mouse capture" or whatever it's called on that
     
    PandadudeSP likes this.
  3. srrw

    srrw Diabloii.Net Member

    Joined:
    Jul 2, 2012
    Messages:
    1,136
    Likes Received:
    680
    Trophy Points:
    233
    Try running "D2VidTst.exe" in your D2 folder, that might fix the issue of not being able to alt-tab.
     
  4. logoutzero

    logoutzero Diabloii.Net Member

    Joined:
    Nov 9, 2005
    Messages:
    1,208
    Likes Received:
    391
    Trophy Points:
    197
    Why can't you tab back to the fullscreen game? Funky colors?

    Just right click on your desktop, and open the "Change desktop resolution" window. Leave that running, don't even interact with it. That will prevent the colors from going wonky.

    If the game is blowing up to widescreen after tabbing, then just change the resolution in game to 640* then back to 800* and it will be in the right aspect again.
     
  5. PandadudeSP

    PandadudeSP Diabloii.Net Member

    Joined:
    Nov 15, 2008
    Messages:
    485
    Likes Received:
    68
    Trophy Points:
    149
    Thanks for the help guys, knew I could count on this forum.
    @logoutzero when i tabbed back it would try and change screen resolution or something and then tab back out to the desktop.

    The fullscreen issue was fixed by disabling aero, and i also installed the glidewrapper.
    The capture mouse setting from the wrapper doesn't capture the mouse when using a -w shortcut however, but only when using the windowed mode in the wrapper. This would be fine except I can't stretch or maximize the window using the wrapper as i can without the wrapper, and I have to change my desktop resolution to increase the relative size of the wrapper.

    Anywho, I guess ill just use the fullscreen which works now!
     
  6. Espr

    Espr Diabloii.Net Member

    Joined:
    Feb 1, 2005
    Messages:
    631
    Likes Received:
    122
    Trophy Points:
    134
    Another way of making the window larger is by using the fixed size options in the wrapper. Rather than a re-sizable window, it scales the image up to a fixed, larger, resolution in the same aspect ratio (ie 1024x768, 1280x960 and so on).
     
    PandadudeSP likes this.

Share This Page