GoMule - null error.

Gynli

Diabloii.Net Member
So... first time I'm having this kind of error on GoMule =P

I get 3 of the same stacktraces on load, and also whenever I try to load a character.
I've also noticed that once the GoMule starts, the icons for adding chars and stashes are missing -
I see boxes instead.

The d2 folder is located in D:\Games\Diablo II\...
GoMule is in D:\Games\Diablo II\Gomule

I forget how to include this in a box but here's the stacktrace:

Error

null
at randall.d2files.D2FileReader.getCounterBoolean(D2FileReader.java:102)
at randall.d2files.D2FileReader.getCounterInt(D2FileReader.java:196)
at randall.d2files.D2TblFile.<init>(D2TblFile.java:81)
at randall.d2files.D2TblFile.readAllFiles(D2TblFile.java:49)
at gomule.gui.D2FileManager.<init>(D2FileManager.java:109)
at gomule.gui.D2FileManager.<clinit>(D2FileManager.java:70)
at gomule.GoMule$1.run(GoMule.java:96)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


I'm reading along the sticked thread for the same error, but the proposed answers haven't helped.
I'll finish reading rest of the 20~ pages, but I'm at a complete loss atm. HELP PLZ!

=(

-- Gynli
 

Gynli

Diabloii.Net Member
well...
I've got the solution, and it had nothing to do with pathing, adming rights, etc etc.
.jar was to be open by AlZip by default.
When I ran GoMule with "Open With..." option and opened with Java, I had the error said above.
When I changed the default to Java, and double clicked to open, it opened without any error.

I do not understand how one works while the other doesn't!?!? anyone?

Well, spending 2 hrs on fixing this error aside, I've started my first char a hungry werebear.
A Pat thread coming soon! - like somewhere around the second half of 2016 lol.
 

logoutzero

Diabloii.Net Member
So you ran it first without decompressing it?

If you download a zip file, you need to do that. It will run within itself, but will be buggy.

Sounds like you got it figured out, but incase not, try right-clicking the file you downloaded and "Extract Files..." and follow the prompts, then double click the new .JAR file that you extract to execute the code.
 

Gynli

Diabloii.Net Member
@logoutzero :
Nah, I did run it after decompressing it.
GoMuleR4.2_1_1.ZIP (I forget the version) was extracted, and in that folder,
GoMule.JAR was ran with "Open with..." option when the default program set to AlZip.

When I changed the default program to Java SE, the problem went away.

I re-downloaded/extracted and changed the default program back to AlZip to double check,
and as far as I know, the "Open with..." was the source of the problem.

I still do not understand how "Open with..." Java SE and default set to Java SE can be different though. =P
 

coju

Diabloii.Net Member
Thank you for coming back and posting your answer. Four years from now, someone will be scouring the Internet with this problem, come across your post, actually find the answer they are looking for, and 'Like' your post.
 

Gynli

Diabloii.Net Member
Ha.!
hopefully in four years time, GoMule will become open source,
for fearedbliss to implement pre 1.09v/classic support,
and all other small tweaks and errors debugged to make it perfect. =D
 

nulio

Diabloii.Net Member
Marshall actually completed the code to make GoMule compatible with 1.06, 1.07, 1.08, and 1.09. But when he attempted to release the code he was unable to get in direct contact with silospen to merge the code with GoMule itself.
 

TheNix

Diabloii.Net Member
Silo is still around last time I looked, at least his twitter account was, but that was a few years back now.
 

Meno

Diabloii.Net Member
Thank you for coming back and posting your answer. Four years from now, someone will be scouring the Internet with this problem, come across your post, actually find the answer they are looking for, and 'Like' your post.
Dude, it's literally 4 years later and this just solved my problem :D:D thanks alot for the solution!
(... sorry for bringing this post back, but this was too funny)
 
Top