Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

getting low fps

Discussion in 'Diablo 2 Patch Bug Reports & Suggestions' started by NickMaillet, Feb 16, 2004.

  1. NickMaillet

    NickMaillet IncGamers Member

    Joined:
    Feb 16, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    getting low fps

    I am playing d2 one day and all of a sudden I started to low get low fps. I thought maybe it was just lagging but after it started to continue i started getting confused. Now every time i play i get low fps almost all the time. I have reinstalled the game and that didn't seem to do anything so i reformatted and reinstalled with only d2 on my comp right now and it is still lagging.I have got the latest drivers for video card so its not that and i have a pretty good computer to run d2 on.2.4ghz,512ram,radeon9000pro. If anyone has any suggestions i would should love to hear them cause d2 just isn't the same anymore cause i like like **** when i do baal runs.
     
  2. klymentt

    klymentt IncGamers Member

    Joined:
    Feb 16, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    What kind of motherboard or motherboard chipset do you have in your machine? Which OS? If running Win2K or earlier, especially on Via-based motherboards, be sure that you have activated dynamic memory acces (DMA) for each of your IDE channels under the system device manager. If any storage devices are in PIO mode and are being accessed while playing, you're likely to get low FPS due to high CPU utilization while using PIO. I hope this helps.

    - K
     
  3. BuddySativa

    BuddySativa IncGamers Member

    Joined:
    Jul 10, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    18
    How low is your low FPS?

    Under 50? 30? 10?? !!
     
  4. NickMaillet

    NickMaillet IncGamers Member

    Joined:
    Feb 16, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    i am running xphome i am not sure what motherboard i have and i don't know how to chnage those settings, and when i am playing i will get a high of 80fps but when it goes to hell which is every 3 seconds i get 2-15 fps
     
  5. Sjafi

    Sjafi IncGamers Member

    Joined:
    Jul 12, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    16
    Same Problem

    I'm having the same problem as you, except im pretty sure my IDE channels are all set to "use dma when available" I'm on win2k using a radeon 7500 w/ 256 ram and a p3 600, this issue seems to be inherit in ATI cards.....is there a certain driver we should get? I have all of mine updated to the latest.

    I also know for a fact that my motherboard is made by the depraved, evil bastards from VIA.
     
  6. BuddySativa

    BuddySativa IncGamers Member

    Joined:
    Jul 10, 2003
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    18
    Are you using the standard Catalyst drivers or an Omega (or other) version ?

    Reason I say this is that I've had some probs with the latest Omega ones and I re-installed earlier versions.

    Diablo was getting locked at 50 fps while I was o/p to tv.

    No O/P to tv, fps went up to screen refresh rate of 85hz.

    Re-installed older drivers and I went to 127 fps.

    Another thing that can knock out your fps (but generally not by much) is something else using system resources - Diablo is a CPU-hungry rather than a graphics-hungry game - it works fine on even a GEForce 2.

    If it's happening every 3 seconds, there may be some form of moitoring s/w running that is hogging resources - check your bios settings, see if there is a temp monitor running?

    Try the orignal ATI 3.9 drivers - I have had problems with the 4.x ones. There are no major speed improvements in the 4.x versions, mainly game-specific fixes.

    Lagging usually applies to ping, rather than fps - but the fps can seriously drop to 1 or less when Shenk explodes etc. See if your ping is going up to high lvls (above 200 - I've had it in the 5000's on bad days) at the same time the fps drops - it may be a connection issue rather than graphics.
     
  7. TheDarkSide

    TheDarkSide Clan Officer - US East Hardcore

    Joined:
    Dec 20, 2003
    Messages:
    2,703
    Likes Received:
    37
    Trophy Points:
    470
    I had a similiar problem a few weeks back . So I thought my video card was bad and went and got a Radeon 9600 and after installing it , my fps still seemed bad . So I popped open my case again and after looking in there I noticed my cpu fan was not spinning fully and was caked up with dust . Cleaned it off , re-installed the fan and boom fps went through the roof . I frequently see 144 fps and never lag in the problem areas like Shenk , Trav , Throne room . Try cleaning that dust out of the case if you havent done so in a while . It sure made a difference in my case .. Good luck ..
     
  8. Monzee

    Monzee IncGamers Member

    Joined:
    Feb 5, 2006
    Messages:
    592
    Likes Received:
    0
    Trophy Points:
    165
    Re: getting low fps

    I am running with up to as much as 2400 fps and I hate it. The reason for this is that my computer starts to make a "beeeping" sound due to the high fps. So I have to run in full screen mode in oder to get it down to a couple of hundreds.
     
  9. LAALOOPA

    LAALOOPA IncGamers Member

    Joined:
    Jun 26, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Re: getting low fps

    hi all 1st time on here i have the lowest fps i have heard off i put tog map on and fps hits 3 YES 3 turn it off and have 20 ne 1 help me i dont have a clue how to fix it and i have just put 2g ram in and phy mem is sitting on 500 ping is 266 going to 5k max fps i get is 55 plz plz plz help me


     

Share This Page