freak problem

lone_wolf

Diablo: IncGamers Member
freak problem

damnit i cant understand whats wrong with my game at all *sigh*

i have a 1200 duron amd
384 MB ram
and a geforec 2 mx 400 64MB grafic card still at every damn thing put off or on the lowest setting

my fps drops to such low values as 8 or worst when ever a pack of monsters enter the screen :grrr:

:rant: what the hell is wrong??????

as it is now i can barely play at all....

there should be no damn lag in sp
 

XaviarGangrel

Diabloii.Net Member
Got anything else running in the background?

I get this problem when running in Windowed mode, or when Norton Antivirus decides to update in the backgorund while I'm playing, slows right down.
 

lone_wolf

Diablo: IncGamers Member
well yeah i got my antivirus on and so is my firewall.

hum hum but they never acted it up before :scratch:
 

Uzziah

Diabloii.Net Member
Try restarting your computer.

Diablo, as well as any other program that is restarted over and over, takes up temporary memory this memory no matter how much you have fills up and that can cause the lag in single player. a simple restart normally clears it.

Boss runs tend to fill up this memory very quickly because you are restarting the program.
 

DMPI_Masher

Diabloii.Net Member
Is you default graphic card setting for the game 2D or 3D? If your graphics card is set to run the game in 3D and you play 2D it will chug your system down. I ran into similar problems and changed the grapics card back to 2D and everything ran great.

I am by far a systems expert, at least I didn't call it the graphics thingy...
 

pesot

Diabloii.Net Member
This a serious problem you're having LW. My pc is only P3550 with voodoo3 and 128mb RAM and d2 never lags even with winamp in the background. Other games lags like crazy, but never d2.

I recommend checking your Virtual Memory settings. windows default would be +12 physical RAM IIRC. you should have double VR from physical RAM. In your case, the VR should be 768 for minimum and max value. this will enable windows to do less page faults and increase system performance. although, it will waste a good space in your HD.

you could also check windows task manager. check if any unwanted program is running in the background. antivirus and firewalls doesn't cause problems like these. unless, like XaviarGangrel said, it's doing an update.

hope that helps.

edit: oh and check if your pc is infected with something.
 

SnakeEye85

Diabloii.Net Member
i also have gf2 and same ram as you

normaly ~20 FPS but about 5-20 in big party or messy crowds...

no "un-needed" programs running the the bg
 

symeon

Diabloii.Net Member
lone_wolf said:
there should be no damn lag in sp
No, there shouldn't, especially since it hasn't been there before. My laptop lags a bit sometimes, only when it's running off the battery. When plugged, the sole time I catch it lagging is Shenk's death animation.

Have you defragmented your disk lately? Defragment and restart your PC. It should be obvious, which is exactly what we tend to overlook.

Good luck
 

Death_Dealer

Diabloii.Net Member
Make sure and move your D2XMusic.mpq file off the CD and into the D2 folder so your game doesn't try and access the CD all the time. That was causing some slowdowns for me for a while until I moved it over.
 

lone_wolf

Diablo: IncGamers Member
ok a update i checked with search and destroy(ad remover) turned up nothing.

checked my antivirus saw it updates every 5 min so turned that of when i played. a bit better.

then i rembered that i once heard that the game is optimized for 3dfx not glide so i changed to 2d mode.

guess what:innocent:

:surprise: never had it runs so smooth as it does now heck i have even had up to 40 fps and such with 17 skip.

he he so for LOD i now play 2d:thumbsup:

ohh and Death_Dealer i have had the mpq files on the hard drive for about a month now.

thats one of the reason i found it very strange.
 
gud wolfy. gald to see the problem solved. i have soem sort of onboard graphics card, lots of RAM and a 1.4MhzAMD. diablo runs fine, even when my fishymancer takes on 3 packs of mosnters all doign there own thing and im running antivirus in the background.
 

cryist

Diabloii.Net Member
lone_wolf said:
then i rembered that i once heard that the game is optimized for 3dfx not glide so i changed to 2d mode.
Mine does the same thing, where did you change the setting from 3dfx to 2d?
 

lone_wolf

Diablo: IncGamers Member
remember the video test cryist??

use that one then after its done it will ask what mod you should use

just click on 2d aka directdraw and then move on from there.

last play the game :thumbsup:

note that you wont have perspective when playing under 2d but i can say that i dont even feel or see the difference anyway.
 
Top