Latest Diablo 3 News
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

Dual Display under Windows 7, I have some issues.

Discussion in 'Diablo 2 Community Forum' started by srrw, Jul 10, 2018.

  1. srrw

    srrw Diabloii.Net Member

    Joined:
    Jul 2, 2012
    Messages:
    1,136
    Likes Received:
    680
    Trophy Points:
    233
    Hey guys, I have a quick question. Mainly to save me the trouble of research and trial and error.

    I run Diablo II on an Acer Monitor and a have a second screen, a 32" LG TV. Both are connected to the PC via the same video card one with DVI cable, one with HDMI cable.

    When Diablo is run on the main screen (Acer) open folders or other applications sometimes move to the right on the TV (Extended Desktop) screen and resolutions are acting weird. Is there an easy way to run Diablo without interfering with the desktop resolution and open folders/apps or should I run it with GlideWrapper or something? I've tried it before, I don't know if it's the settings but the quality drops significantly when ran with it.

    The end goal is to play Diablo on the main screen and watch TV shows on the extended desktop. And how to stop Diablo from changing the default desktop resolution when ran?

    Please feel free to ask for any other information because I still feel I've not explained everything properly.
     
  2. krischan

    krischan Europe Trade Moderator

    Joined:
    Aug 17, 2003
    Messages:
    30,236
    Likes Received:
    1,169
    Trophy Points:
    416
    You could try the glide wrapper make a few experiments with the settings program. I would start with activating the "desktop resolution" option which makes the 800x600 graphics scale up to the monitor resolution. That setting also decreases wait time during games a lot! The "keep asect ratio" setting will avoid distortions if the monitor isn't 4:3 (most probably the case), but lead to black bars to the left and right. It's either that or fat guys with pumpkin heads. If it doesn't help, you could also try the window mode setting and perhaps mouse capture.

    When using the glide wrapper with V1.14+, also add -3dfx to the D2 command line, alse the game won't use glide.
     
    Last edited: Jul 11, 2018
  3. srrw

    srrw Diabloii.Net Member

    Joined:
    Jul 2, 2012
    Messages:
    1,136
    Likes Received:
    680
    Trophy Points:
    233
    No matter what I do with the texture settings the outcome is the same.
    No Glide
    Glide
    The blurriness hurts my eyes. Everything else runs fine when run with glide. Am I doing something wrong or is it just supposed to run this way?
     
  4. krischan

    krischan Europe Trade Moderator

    Joined:
    Aug 17, 2003
    Messages:
    30,236
    Likes Received:
    1,169
    Trophy Points:
    416
    Hmm, I thought the problem is about the rest of the desktop acting weirdly and not the game being blurry.

    The game's inherent resolution cannot be higher than 800x600. When displaying it in a higher resolution, it will just be magnified without inccreasing the resolution of the game. If you see a blown up game screen next to your 1920x1080 desktop, it will appear either blocky or blurry.

    Did you try windowed mode via the wrapper settings, not via -w in the command line? If you put a checkmark to "windowed mode" and "window extras", you will have a resizable window which can be rescaled to whatever you like.

    BTW, I don't have two monitors connected to my computer, so others might have more to add to the matter :)
     
  5. srrw

    srrw Diabloii.Net Member

    Joined:
    Jul 2, 2012
    Messages:
    1,136
    Likes Received:
    680
    Trophy Points:
    233
    I'm completely fine with the way the game runs full screen 16:9. But when I run it normally I simply can't use the second monitor because the desktop resolution screws up. On the other hand when ran with glidewrapper the resolution and second display act as they should but the game becomes unplayable because of the eye-watering blur. Thanks anyway @krischan
     

Share This Page