Diablo 2 Version 1.0 Play Disc in your CD-ROM solution


Diabloii.Net Member
Diablo 2 version 1.0 please insert play disc error
Diablo II failed to run.
Please make sure your Diablo II Play Disc is in your CD-ROM drive, then click on 'Retry'.
Never saw a solution online for my problem, hopefully this will help other people out.

Install classic Diablo II version 1.0
After the video test select DirectDraw 2D. I couldn't get it to run in 3D selection.
set windows 7 theme to windows classic (right click desktop, click personalize, find windows classic theme).
Right click Diablo II icon select properties, click Compatibility tab.
Check Run the compatibility mode for Windows 7.
then right click any where on your desktop, and click screen resolution.
then double click diablo ii icon and play.

If any of you guys have any solution to play in 3D please let me know how you did it.


Diabloii.Net Member
Google sven's glide wrapper

Worked for me, but made videos black. I've seen those so many times anyway, so it didn't really matter to me.


Diabloii.Net Member
I'm guessing it's a system/hardware issue (drivers), as with the patching to most recent version, it should work fine on windows 7. So, unless you can can make your own drivers (assembly and/or other low level programming) to allow the version 1.0 of diablo 2 to work with your wondows 7 OS and the computer's hardware, you're going to have to use the patches, as they do it for you.


Diabloii.Net Member
Anyone know a solution to my problem?

I installed D2 from my original CD and updated to 1.06 version. Now I try to launch the game but it doesn't show anything on the screen.

If I look at the taskmanager I see Game.exe running and DiabloII.exe running, but nothing happens. Game.exe takes a lot of CPU time also 99%?

I try to run the game in VirtualBox with Windows XP installed.

I tried with Directdraw and sven's glide wrapper. Both have same effect.

The game works okey with 1.12+ versions which do not require a CD in a drive. Could it be a CD issue .. cannot load something there? Maybe I need to make an image of the CD and mount it in the Virtual Machine.

I'm planning to play some 1.06 with multiple characters in TCP/IP.. (IIRC there was no working solution for Loader in 1.06 version)