Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

cannot fullscreen thats not stretched

Discussion in 'Diablo 2 Patch Bug Reports & Suggestions' started by thundershock, Aug 10, 2010.

  1. thundershock

    thundershock IncGamers Member

    Joined:
    Aug 28, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cannot fullscreen thats not stretched

    hello. I need your help. I have a 20" widescreen lcd and I cant seem to find a way to make diablo 2 lod in full screen, not stretched with black border on the sides (http://i170.photobucket.com/albums/u263/fex_dominate/screennormal.jpg) after I patched 1.13. I applied -w -nofixaspect and try to stretch the window but I cant. I maximized the window and it made the window bigger without fully stretching but the graphics is not as good as when I run diablo fullscreen not -w mode. Ive read from that you need to go to nvidia control panel and I did but there is no scaling/stretching option or adjust desktop size position. My video card is geforce fx 5500. Is this because of my video card or is there another solution to my problem?
     
  2. SeCKSEgai

    SeCKSEgai IncGamers Member

    Joined:
    Jan 12, 2009
    Messages:
    1,947
    Likes Received:
    0
    Trophy Points:
    165
    Re: cannot fullscreen thats not stretched

    With a widescreen, you will get a stretched image if you go full screen with no black bars - the maximum resolution is 800x600 - a limitation as the game code was written years ago.

    While I generally run in window, the black bars are there to maintain aspect ratio.

    If you're referring to windowed mode distorting when you maximize the window, I believe that's fallout for mixing the two resolutions (ie 800x600 on a 1400x900 desktop)

    And just to clarify, 800x600 is a box, and widescreen support was never implemented, though I'm sure it will be standard when d3 comes out.
     
  3. ffejrxx

    ffejrxx IncGamers Member

    Joined:
    Nov 26, 2005
    Messages:
    6,286
    Likes Received:
    13
    Trophy Points:
    166
    Re: cannot fullscreen thats not stretched

    if your computer has an ati or nvidia video card, you can do full screen with bars on the sides

    give the glide wrapper a shot
    remove the -w from your d2 shortcut

    http://www.svenswrapper.de/english/downloads.html
    download gl32ogl14d.zip and unzip to your d2 install folder
    run glide-init.exe, pick english/dutch, opengl-infos, query opengl-infos
    if nothing is listed under unsupported extensions its fine
    pick settings
    tick keep aspect ratio, desktop resolution, and vsync
    then test to verify it works

    if its successful (framerate stays higher than 25)
    run D2VidTst.exe -> run testes -> pick glide
     
  4. thundershock

    thundershock IncGamers Member

    Joined:
    Aug 28, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Re: cannot fullscreen thats not stretched

    @SeCKSEgai thanks for the info

    @ffejrxx it worked. thanks
     
  5. SeCKSEgai

    SeCKSEgai IncGamers Member

    Joined:
    Jan 12, 2009
    Messages:
    1,947
    Likes Received:
    0
    Trophy Points:
    165
    Re: cannot fullscreen thats not stretched

    Oh, if you want to use the entire screen with the proper ratio, the widescreen gaming forum was able to do so - however, I think they did have to modify game files, so unless you're strictly SP I wouldn't bother with it.
     
  6. ffejrxx

    ffejrxx IncGamers Member

    Joined:
    Nov 26, 2005
    Messages:
    6,286
    Likes Received:
    13
    Trophy Points:
    166
    Re: cannot fullscreen thats not stretched

    there was a mod that made it full screen res, but was disabled for bnet

    glide wrapper works fine on bnet, as the game doesnt detect it
    its glide3x.dll converts glide to opengl better than the D2Direct3D.dll preforms on any high end card
     
  7. thundershock

    thundershock IncGamers Member

    Joined:
    Aug 28, 2008
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Re: cannot fullscreen thats not stretched

    @ ffejrxx glide works really well. The graphics improved significantly after I read the notes below and changed the settings specially the texture memory.
     
  8. SeCKSEgai

    SeCKSEgai IncGamers Member

    Joined:
    Jan 12, 2009
    Messages:
    1,947
    Likes Received:
    0
    Trophy Points:
    165
    Re: cannot fullscreen thats not stretched

    It's not so much detection as simply changing graphic drivers. I was actually surprised a game that old didn't have opengl support since direct3d didn't force opengl out till a bit later.

    Thanks for the link to that glidewrapper =)
     

Share This Page