Diablo I on a Mac?


A fan of Diablo I (a game that’s exhaustively-documented in the DiabloWiki) asked how he might play it on his modern Mac, got a blue reply, then found his own solution. The is Blizzard tech post is here, and in it Datth said:

The original Diablo is not coded to run on that version of the OS. You may be able to find emulators for older versions of that OS to run on top of your current one but those methods are unsupported by us.

Inspired by this semi-advice, the poster went looking on his own, and came back to report success, which = advice for anyone else with his problem.

Thanks for the reply!

I looked up those emulators and found one, called SheepShaver, which is supposed to create an environment as if one had an old Mac OS, but it seemed way too complicated to install and run.

However, I did find a solution! I tried to install a windows version of Diablo on my Macbook using a program, called CrossOver, which makes it possible to install and run applications for windows on a mac. To my surprise, Diablo did run with this program! The only flaw is that the menu isn’t displayed correctly, so I had to navigate blindly to create a new character. Fortunately, the cinematics and the game itself seem to run pretty well!

It’s great to see this old game run again 😀

Comments

You're not logged in. Register or login to post a comment.