Diablo 3 Achievements Display Bug


Some players are reporting a Diablo 3 Achievements Display Bug when trying to view DiabloWikiAchievements (theirs and others). Blizzard have advised logging in and out again which is working for some people. Others it doesn’t and still their Achievements will not display. Blizzard have assured everyone that it is a display problem and that achievements are being tracked and logged and they are looking into fixing the problem.

There have been a few reports that the achievement interface is showing the errors “Game Data Text Goes Here” and “!!MISSING!!” and doesn’t display any achievements afterwards. If you’re encountering this issue, please try logging in and out of the game a few times and it should resolve itself. No achievements were removed.
I just wanted to chime in and let all of you know that we are aware that we are actively investigating this issue, and hope to have a resolution in place soon.

In the short term, the log out workaround (detailed here) is working for many players and we encourage you to give that a try if you are experiencing this. Please note that this is just a temporary workaround, and may not work for all players. If this does not work for you right away, please wait a short while and try again.

We really appreciate your patience while we are working on a permanent resolution. Thank you all for the reports about this!

I can’t seem to connect to even check if I have the problem. It could be pretty rare.

Comments

You're not logged in. Register or login to post a comment.
  1. yep, I got that one and they posted a workaround that I'm trying to see if it works, but the damn DDOS is crippling the servers like no tomorrow lately.

  2. I had this pop up. May have been related to a slow connection.

  3. This is what it took for me: log out, SWITCH REALMS, log in, log out, SWITCH BACK HOME, log in.

    • I did this and it worked. I have one bugged achievement with Hardcore Act 5 champs all ticked but achievement is not given.

  4. May be fixed because I am not getting a problem with achievement display

  5. Ever since version 2.1.0, I’ve been having the same problem.

Comments are closed.